GHSA-98vj-mm79-v77rMediumCVSS 6.6

Contao is vulnerable to remote code execution in template closures

Published
November 25, 2025
Last Modified
November 27, 2025

🔗 CVE IDs covered (1)

📋 Description

Impact

Backend users with precise control over the contents of template closures can execute arbitrary PHP functions that do not have required parameters.

Patches

Update to Contao 4.13.57, 5.3.42 or 5.6.5

Workarounds

Manually patch the Contao\Template::once() method.

Resources

https://contao.org/en/security-advisories/remote-code-execution-in-template-closures

🎯 Affected products3

  • composer/contao/core-bundle:>= 4.0.0, < 4.13.57
  • composer/contao/core-bundle:>= 5.0.0-RC1, < 5.3.42
  • composer/contao/core-bundle:>= 5.4.0-RC1, < 5.6.5

🔗 References (7)