GHSA-92cc-952p-v8rhHighCVSS 7.3

Apache Hadoop HDFS Native Client has Out-of-bounds Write Vulnerability

Published
January 26, 2026
Last Modified
January 26, 2026

🔗 CVE IDs covered (1)

📋 Description

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

🎯 Affected products1

  • maven/org.apache.hadoop:hadoop-hdfs-native-client:>= 3.2.0, < 3.4.2

🔗 References (7)