GHSA-8xc6-g8xw-h2c4HighCVSS 7.5

YARP Denial of Service Vulnerability

Published
April 22, 2022
Last Modified
January 27, 2023

🔗 CVE IDs covered (1)

📋 Description

Impact

A denial of service vulnerability exists in how YARP processes input.

Patches

If you're using YARP 1.0.0, you should update to NuGet package version 1.0.1. If you're using YARP 1.1.0-RC.1, you should update to NuGet package version 1.1.0-rc.1.22211.2.

You can do so by updating the PackageReference in your .csproj file

<ItemGroup>
- <PackageReference Include="Yarp.ReverseProxy" Version="1.0.0" />
- <PackageReference Include="Yarp.Telemetry.Consumption" Version="1.0.0" />
+ <PackageReference Include="Yarp.ReverseProxy" Version="1.0.1" />
+ <PackageReference Include="Yarp.Telemetry.Consumption" Version="1.0.1" />
</ItemGroup>

or by selecting 1.0.1 in the NuGet UI inside Visual Studio (Manage NuGet Packages / Updates) image

References

CVE-2022-26924

🎯 Affected products2

  • nuget/Yarp.ReverseProxy:< 1.0.1
  • nuget/Yarp.ReverseProxy:= 1.1.0-rc.1.22152.1

🔗 References (6)