GHSA-8w65-xjc5-9w79MediumCVSS 5.4
Cross-Site Scripting in node-red
🔗 CVE IDs covered (1)
📋 Description
Versions of node-red prior to 0.20.8are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize the name field in new Flows, allowing attackers to execute arbitrary JavaScript in the victim's browser.
Recommendation
Upgrade to version 0.18.6 or later.
🎯 Affected products1
- npm/node-red:<= 0.20.7