GHSA-8w3p-qh3x-6gjrMediumCVSS 5.7

TYPO3 CMS vulnerable to Sensitive Information Disclosure via YAML Placeholder Expressions in Site Configuration

Published
December 13, 2022
Last Modified
October 29, 2024

🔗 CVE IDs covered (1)

📋 Description

CVSS: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:L/A:L/E:F/RL:O/RC:C (5.3)

Problem

Due to the lack of handling user-submitted YAML placeholder expressions in the site configuration backend module, attackers could expose sensitive internal information, such as system configuration or HTTP request messages of other website visitors.

A valid backend user account having administrator privileges is needed to exploit this vulnerability.

Solution

Update to TYPO3 versions 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1 that fix the problem described above.

Credits

Thanks to TYPO3 core & security team member Oliver Hader who reported and fixed the issue.

References

🎯 Affected products7

  • composer/typo3/cms-core:>= 9.0.0, < 9.5.38
  • composer/typo3/cms-core:>= 10.0.0, < 10.4.33
  • composer/typo3/cms-core:>= 11.0.0, < 11.5.20
  • composer/typo3/cms-core:>= 12.0.0, < 12.1.1
  • composer/typo3/cms:>= 10.0.0, < 10.4.33
  • composer/typo3/cms:>= 11.0.0, < 11.5.20
  • composer/typo3/cms:>= 12.0.0, < 12.1.1

🔗 References (7)