GHSA-8rhc-48pp-52grHighCVSS 7.8

Apache Spark Deserialization of Untrusted Data vulnerability

Published
November 9, 2018
Last Modified
November 26, 2024

🔗 CVE IDs covered (1)

📋 Description

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.1.2, 2.2.0 or later.

🎯 Affected products3

  • maven/org.apache.spark:spark-core_2.11:< 2.1.2
  • maven/org.apache.spark:spark-core_2.10:< 2.1.2
  • pip/pyspark:< 2.1.2

🔗 References (4)