GHSA-8qxg-mff5-j3wcMediumCVSS 5.5

RubyGems Path Traversal vulnerability

Published
May 14, 2022
Last Modified
March 10, 2023

🔗 CVE IDs covered (1)

📋 Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem writing to arbitrary filesystem locations during installation. This attack appears to be exploitable via installation of a malicious gem. This vulnerability is fixed in 2.7.6.

🎯 Affected products2

  • rubygems/rubygems-update:< 2.7.6
  • maven/org.jruby:jruby-stdlib:< 9.1.16.0

🔗 References (21)