GHSA-8pxv-x6jq-5vw9HighCVSS 6.5

Apache Syncope Improper Input Validation vulnerability

Published
July 22, 2024
Last Modified
November 18, 2024

🔗 CVE IDs covered (1)

📋 Description

When editing a user, group or any object in the Syncope Console, HTML tags could be added to any text field and could lead to potential exploits. The same vulnerability was found in the Syncope Enduser, when editing "Personal Information" or "User Requests".

Users are recommended to upgrade to version 3.0.8, which fixes this issue.

🎯 Affected products2

  • maven/org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui:>= 2.1.0, < 3.0.8
  • maven/org.apache.syncope.client.idrepo:syncope-client-idrepo-console:>= 2.1.0, < 3.0.8

🔗 References (6)