GHSA-8p5c-f836-m4h7CriticalCVSS 9.8
Magento 2 Community Edition XML Injection
🔗 CVE IDs covered (1)
📋 Description
An XPath entity injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An attacker can craft a GET request to page cache block rendering module that gets passed to XML data processing engine without validation. The crafted key/value GET request data allows an attacker to limited access to underlying XML data.
As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
🎯 Affected products2
- composer/magento/community-edition:>= 2.2.0, < 2.2.10
- composer/magento/community-edition:>= 2.3.0, < 2.3.2-p2
🔗 References (5)
- https://nvd.nist.gov/vuln/detail/CVE-2019-8158
- https://web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8158.yaml
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- https://github.com/advisories/GHSA-8p5c-f836-m4h7