GHSA-8mr5-h28g-36qxHighCVSS 7.5

Spring AOP functionality (Struts) vulnerable to DoS attack

Published
October 16, 2018
Last Modified
January 4, 2024

🔗 CVE IDs covered (1)

📋 Description

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

🎯 Affected products2

  • maven/org.apache.struts:struts2-core:>= 2.5.0, < 2.5.12
  • maven/org.apache.struts:struts2-core:>= 2.3.7, < 2.3.33

🔗 References (11)