GHSA-8mq9-fqv8-59wfMediumCVSS 6.4

Cross-Site Scripting in Page Preview

Published
July 22, 2021
Last Modified
February 5, 2024

🔗 CVE IDs covered (1)

📋 Description

Meta

  • CVSS: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC (5.0)

Problem

Failing to properly encode Page TSconfig settings, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability.

Solution

Update to TYPO3 versions 9.5.28, 10.4.18, 11.3.1 that fix the problem described.

Credits

Thanks to TYPO3 core merger Oliver Bartsch who reported and fixed the issue.

References

🎯 Affected products6

  • composer/typo3/cms-core:>= 9.0.0, < 9.5.28
  • composer/typo3/cms-core:>= 10.0.0, < 10.4.18
  • composer/typo3/cms-core:>= 11.0.0, < 11.3.1
  • composer/typo3/cms:>= 10.0.0, < 10.4.18
  • composer/typo3/cms:>= 11.0.0, < 11.3.1
  • composer/typo3/cms:>= 9.0.0, < 9.5.28

🔗 References (7)