GHSA-8j4w-5fw4-rm27CriticalCVSS 9.8
Prototype Pollution in deeply
🔗 CVE IDs covered (1)
📋 Description
Versions of deeply prior to 1.0.1 are vulnerable to Prototype Pollution. The package fails to validate which Object properties it updates. This allows attackers to modify the prototype of Object, causing the addition or modification of an existing property on all objects.
Recommendation
Upgrade to version 3.1.0 or later.
🎯 Affected products1
- npm/deeply:< 3.1.0