GHSA-8gv3-3j7f-wg94HighCVSS 8.7
Potential Remote Code Execution vulnerability
🔗 CVE IDs covered (1)
📋 Description
Packages nette/application versions prior to 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette versions prior to 2.0.19 and 2.1.13 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE.
Reported by Cyku Hong from DEVCORE (https://devco.re)
Impact
Code injection, possible remote code execution.
Patches
Fixed in nette/application 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette 2.0.19 and 2.1.13
🎯 Affected products6
- composer/nette/application:>= 2.2.0, < 2.2.10
- composer/nette/application:>= 2.3.0, < 2.3.14
- composer/nette/application:>= 2.4.0, < 2.4.16
- composer/nette/application:>= 3.0.0, < 3.0.6
- composer/nette/application:>= 2.0.0, < 2.0.19
- composer/nette/application:>= 2.1.0, < 2.1.13
🔗 References (8)
- https://github.com/nette/application/security/advisories/GHSA-8gv3-3j7f-wg94
- https://packagist.org/packages/nette/application
- https://packagist.org/packages/nette/nette
- https://nvd.nist.gov/vuln/detail/CVE-2020-15227
- https://lists.debian.org/debian-lts-announce/2021/04/msg00003.html
- https://blog.nette.org/en/cve-2020-15227-potential-remote-code-execution-vulnerability
- https://github.com/FriendsOfPHP/security-advisories/blob/master/nette/application/CVE-2020-15227.yaml
- https://github.com/advisories/GHSA-8gv3-3j7f-wg94