GHSA-86mr-6m89-vgj3MediumDisclosed before NVD
Buffer Overflow in node-weakauras-parser
📋 Description
Affected versions of node-weakauras-parser are vulnerable to a Buffer Overflow. The encode_weakaura function fails to properly validate the input size. A buffer of 13835058055282163711 bytes causes an overflow on 64-bit systems.
Recommendation
Upgrade to versions 1.0.5, 2.0.2, 3.0.1 or later.
🎯 Affected products3
- npm/node-weakauras-parser:>= 1.0.4, < 1.0.5
- npm/node-weakauras-parser:>= 2.0.0, < 2.0.2
- npm/node-weakauras-parser:>= 3.0.0, < 3.0.1