GHSA-82mg-x548-gq3jHighCVSS 7.5

LDAP Injection in ldapauth

Published
August 31, 2020
Last Modified
January 9, 2023

🔗 CVE IDs covered (1)

📋 Description

Versions 2.2.4 and earlier of ldapauth-fork are affected by an LDAP injection vulnerability. This allows an attacker to inject and run arbitrary LDAP commands via the username parameter.

Recommendation

ldapauth is not actively maintained, having not seen a publish since 2014. As a result, there is no patch available. Consider updating to use ldapauth-fork 2.3.3 or greater.

🎯 Affected products2

  • npm/ldapauth-fork:< 2.3.3
  • npm/ldapauth:< 2.2.4

🔗 References (9)