GHSA-7pgf-ppxw-8624HighCVSS 7.5
Apache Zeppelin exposes server resources to unauthenticated attackers
🔗 CVE IDs covered (1)
📋 Description
The attacker can use the raft server protocol in an unauthenticated way. The attacker can see the server's resources, including directories and files.
This issue affects Apache Zeppelin: from 0.10.1 up to 0.12.0.
Users are recommended to upgrade to version 0.12.0, which fixes the issue by removing the Cluster Interpreter.
🎯 Affected products2
- maven/org.apache.zeppelin:zeppelin-interpreter:>= 0.10.1, < 0.12.0
- maven/org.apache.zeppelin:zeppelin-server:>= 0.10.1, < 0.12.0
🔗 References (6)
- https://nvd.nist.gov/vuln/detail/CVE-2024-41169
- https://github.com/apache/zeppelin/pull/4841
- https://issues.apache.org/jira/browse/ZEPPELIN-6101
- https://lists.apache.org/thread/moyym04993c8owh4h0qj98r43tbo8qdd
- http://www.openwall.com/lists/oss-security/2025/07/13/1
- https://github.com/advisories/GHSA-7pgf-ppxw-8624