GHSA-7mqg-5fgh-xh4rHighCVSS 7.5

MediaWiki Incorrect Access Control vulnerability

Published
May 24, 2022
Last Modified
May 24, 2024

🔗 CVE IDs covered (1)

📋 Description

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

🎯 Affected products4

  • composer/mediawiki/core:>= 1.18.0, < 1.27.6
  • composer/mediawiki/core:>= 1.30.0, < 1.30.2
  • composer/mediawiki/core:>= 1.31.0, < 1.31.2
  • composer/mediawiki/core:>= 1.32.0, < 1.32.2

🔗 References (5)