GHSA-7c58-g782-9j38High
Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI
🔗 CVE IDs covered (1)
📋 Description
Craft CMS contains a potential remote code execution vulnerability via Twig SSTI. You must have administrator access and ALLOW_ADMIN_CHANGES must be enabled for this to work.
https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production
Note: This is a follow-up to https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv
Users should update to the patched versions (4.14.13 and 5.6.15) to mitigate the issue.
References
https://github.com/craftcms/cms/pull/17026
🎯 Affected products2
- composer/craftcms/cms:>= 4.0.0-RC1, <= 4.14.12
- composer/craftcms/cms:>= 5.0.0-RC1, <= 5.6.14
🔗 References (6)
- https://github.com/craftcms/cms/security/advisories/GHSA-7c58-g782-9j38
- https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv
- https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production
- http://github.com/craftcms/cms/pull/17026
- https://nvd.nist.gov/vuln/detail/CVE-2025-46731
- https://github.com/advisories/GHSA-7c58-g782-9j38