GHSA-7889-rm5j-hpggMediumCVSS 4.6

Clipboard feature vulnerability allowing to inject arbitrary HTML into the editor using paste functionality

Published
August 23, 2021
Last Modified
February 1, 2023

🔗 CVE IDs covered (1)

📋 Description

Affected packages

The vulnerability has been discovered in clipboard plugin. All plugins with clipboard plugin dependency are affected:

Impact

A potential vulnerability has been discovered in CKEditor 4 Clipboard package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2.

Patches

The problem has been recognized and patched. The fix will be available in version 4.16.2.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 4 team would like to thank Anton Subbotin (skavans) for recognizing and reporting this vulnerability.

🎯 Affected products1

  • npm/ckeditor4:>= 4.5.2, < 4.16.2

🔗 References (8)