GHSA-77qv-gh6f-pgh4LowCVSS 3.8
Command Injection in Limdu
🔗 CVE IDs covered (1)
📋 Description
Impact
The trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability.
Patches
Patched in version 0.9.5.
Workarounds
Do not use trainBatch with classifiers that rely on shell execution, such as SVM Perf, SVM Linear or Adaboost
References
No
🎯 Affected products1
- npm/limdu:<= 0.9.4