GHSA-7753-xrfw-ch36HighCVSS 8.6

LlamaIndex affected by a Denial of Service (DOS) in JSONReader

Published
August 26, 2025
Last Modified
August 26, 2025

🔗 CVE IDs covered (1)

📋 Description

A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.

🎯 Affected products1

  • pip/llama-index-core:< 0.12.38

🔗 References (4)