GHSA-76wm-422q-92mqHighCVSS 8.8

Code injection in RubyGems

Published
June 20, 2019
Last Modified
August 28, 2023

🔗 CVE IDs covered (1)

📋 Description

An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

🎯 Affected products2

  • rubygems/rubygems-update:>= 2.6.0, < 2.7.9
  • rubygems/rubygems-update:>= 3.0.0, < 3.0.2

🔗 References (7)