GHSA-73v8-v6g4-vrpmHighDisclosed before NVD
Arbitrary File Overwrite in decompress-zip
📋 Description
Vulnerable versions of decompress-zip are affected by the Zip-Slip vulnerability, an arbitrary file write vulnerability. The vulnerability occurs because decompress-zip does not verify that extracted files do not resolve to targets outside of the extraction root directory.
Recommendation
For decompress-zip 0.2.x upgrade to 0.2.2 or later.
For decompress-zip 0.3.x upgrade to 0.3.2 or later.
🎯 Affected products2
- npm/decompress-zip:< 0.2.2
- npm/decompress-zip:>= 0.3.0, < 0.3.2