GHSA-73jp-3c67-hjfvHighCVSS 8.1

Authentication Bypass in passport-azure-ad

Published
July 26, 2018
Last Modified
January 9, 2023

🔗 CVE IDs covered (1)

📋 Description

Affected versions of passport-azure-ad do not recognize the validateIssuer setting, which allows remote attackers to bypass authentication via a crafted token.

Recommendation

Version 1.x: Update to version 1.4.6 or later. Version 2.x: Update to version 2.0.1 or later.

🎯 Affected products2

  • npm/passport-azure-ad:>= 1.0.0, < 1.4.6
  • npm/passport-azure-ad:= 2.0.0

🔗 References (8)