GHSA-724c-6vrf-99rqLowDisclosed before NVD

Sensitive Data Exposure in loopback

Published
September 2, 2020
Last Modified
January 9, 2023

📋 Description

Versions of loopback prior to 3.26.0 (3.x) and 2.42.0 (2.x) are vulnerable to Sensitive Data Exposure. Invalid API requests to the login endpoint may return information about the first user in the database. This can be used alongside other attacks for credential theft.

Recommendation

If you're using loopback 3.x upgrade to version 3.26.0 or later. If you're using loopback 2.x upgrade to version 2.42.0 or later.

🎯 Affected products2

  • npm/loopback:<= 2.41.0
  • npm/loopback:>= 3.0.0, <= 3.25.0

🔗 References (4)