GHSA-6q4w-3wp4-q5wfHighCVSS 7.5
Denial of Service in get-ip-range
🔗 CVE IDs covered (1)
📋 Description
The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion. Update get-ip-range dependency to 4.0.0 or above.
🎯 Affected products1
- npm/get-ip-range:< 4.0.0
🔗 References (6)
- https://nvd.nist.gov/vuln/detail/CVE-2021-27191
- https://github.com/JoeScho/get-ip-range/commit/98ca22b815c77273cbab259811ab0976118e13b6
- https://www.npmjs.com/package/get-ip-range
- https://security.netapp.com/advisory/ntap-20210319-0002/
- https://advisory.checkmarx.net/advisory/CX-2021-4304
- https://github.com/advisories/GHSA-6q4w-3wp4-q5wf