GHSA-6g87-ff9q-v847HighCVSS 7.5
websockets is vulnerable to denial of service by memory exhaustion
🔗 CVE IDs covered (1)
📋 Description
The Python websockets library version 4 contains a CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Servers and clients, unless configured with compression=None that can result in Denial of Service by memory exhaustion. This attack appears to be exploitable via sending a specially crafted frame on an established connection. This vulnerability appears to have been fixed in version 5.0
🎯 Affected products1
- pip/websockets:>= 4.0, < 5.0