GHSA-6898-wx94-8jq8CriticalCVSS 9.8

Potential Command Injection in libnotify

Published
August 31, 2020
Last Modified
September 8, 2023

🔗 CVE IDs covered (1)

📋 Description

Versions 1.0.3 and earlier of libnotify are affected by a shell command injection vulnerability. This may result in execution of arbitrary shell commands, if user input is passed into libnotify.notify.

Untrusted input passed in the call to libnotify.notify could result in execution of shell commands. Callers may be unaware of this.

Example

var libnotify = require('libnotify')
libnotify.notify('UNTRUSTED INPUT', { title: \"\" }, function () {
    console.log(arguments);
})

Special thanks to Neal Poole for submitting the pull request to fix this issue.

Recommendation

Update to version 1.0.4 or greater

🎯 Affected products1

  • npm/libnotify:<= 1.0.3

🔗 References (6)