GHSA-66xp-28cq-mrf2HighCVSS 7.5
Moodle Denial of Service
🔗 CVE IDs covered (1)
📋 Description
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
🎯 Affected products4
- composer/moodle/moodle:>= 3.9, < 3.9.2
- composer/moodle/moodle:>= 3.8, < 3.8.5
- composer/moodle/moodle:>= 3.7, < 3.7.8
- composer/moodle/moodle:>= 3.5, < 3.5.14