GHSA-66mv-xh68-h6v2HighDisclosed before NVD

Denial of Service in @commercial/hapi

Published
September 3, 2020
Last Modified
January 9, 2023

📋 Description

Affected versions of @commercial/hapi are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Recommendation

Upgrade to versions 16.8.2, 17.9.2, 18.4.1, 19.1.1 or later.

🎯 Affected products4

  • npm/@commercial/hapi:< 16.8.2
  • npm/@commercial/hapi:>= 17.0.0, < 17.9.2
  • npm/@commercial/hapi:>= 18.0.0, < 18.4.1
  • npm/@commercial/hapi:>= 19.0.0, < 19.1.1

🔗 References (2)