GHSA-6677-83pp-f862MediumCVSS 6.1
Cross-Site Scripting in @nuxt/devalue
🔗 CVE IDs covered (1)
📋 Description
Versions of @nuxt/devalue prior to 1.2.3 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization attacker may inject arbitrary JavaScript code through object keys.
Recommendation
Upgrade to version 1.2.3 or later.
🎯 Affected products1
- npm/@nuxt/devalue:< 1.2.3
🔗 References (9)
- https://nvd.nist.gov/vuln/detail/CVE-2019-13506
- https://github.com/nuxt/devalue/pull/8
- https://github.com/nuxt/devalue/releases/tag/v1.2.3
- https://github.com/nuxt/nuxt.js/commit/0d5dfe71917191c5b07f373896311f2d8f6b75be
- https://github.com/nuxt/nuxt.js/compare/c0776eb...8d14cd4
- https://github.com/nuxt/nuxt.js/releases/tag/v2.6.2
- https://www.npmjs.com/advisories/814
- https://github.com/Rich-Harris/devalue/issues/19
- https://github.com/advisories/GHSA-6677-83pp-f862