GHSA-6226-h7ff-ch6cHighCVSS 7.6

Widget feature vulnerability allowing to execute JavaScript code using undo functionality

Published
August 23, 2021
Last Modified
February 1, 2023

🔗 CVE IDs covered (1)

📋 Description

Affected packages

The vulnerability has been discovered in Widget plugin if used alongside Undo feature.

Impact

A potential vulnerability has been discovered in CKEditor 4 Widget package. The vulnerability allowed to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0.

Patches

The problem has been recognized and patched. The fix will be available in version 4.16.2.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 4 team would like to thank Anton Subbotin (skavans) for recognizing and reporting this vulnerability.

🎯 Affected products1

  • npm/ckeditor4:>= 4.13.0, < 4.16.2

🔗 References (9)