GHSA-5xvc-vgmp-jgc3CriticalCVSS 9.1

Improper Access Control in jupyterhub-firstuseauthenticator

Published
October 28, 2021
Last Modified
September 24, 2024

🔗 CVE IDs covered (1)

📋 Description

Impact

When JupyterHub is used with FirstUseAuthenticator, the vulnerability allows unauthorized access to any user's account if create_users=True and the username is known or guessed.

Patches

Upgrade to jupyterhub-firstuseauthenticator to 1.0, or apply patch https://github.com/jupyterhub/firstuseauthenticator/pull/38.patch

Workarounds

If you cannot upgrade, there is no complete workaround, but it can be mitigated.

If you cannot upgrade yet, you can disable user creation with c.FirstUseAuthenticator.create_users = False, which will only allow login with fully normalized usernames for already existing users prior to jupyterhub-firstuserauthenticator 1.0. If any users have never logged in with their normalized username (i.e. lowercase), they will still be vulnerable until you can patch or upgrade.

🎯 Affected products1

  • pip/jupyterhub-firstuseauthenticator:< 1.0.0

🔗 References (9)