GHSA-5w2h-59j3-8x5wHighCVSS 7.2

TYPO3 Install Tool vulnerable to Code Execution

Published
February 13, 2024
Last Modified
September 15, 2025

🔗 CVE IDs covered (1)

📋 Description

Problem

Several settings in the Install Tool for configuring the path to system binaries were vulnerable to code execution. Exploiting this vulnerability requires an administrator-level backend user account with system maintainer permissions.

The corresponding change for this advisory involves enforcing the known disadvantages described in TYPO3-PSA-2020-002: Protecting Install Tool with Sudo Mode.

Solution

Update to TYPO3 versions 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, 13.0.1 that fix the problem described.

Credits

Thanks to Rickmer Frier & Daniel Jonka who reported this issue and to TYPO3 core & security team member Benjamin Franzke who fixed the issue.

References

🎯 Affected products6

  • composer/typo3/cms-core:>= 8.0.0, <= 8.7.56
  • composer/typo3/cms-core:>= 9.0.0, <= 9.5.45
  • composer/typo3/cms-core:>= 10.0.0, <= 10.4.42
  • composer/typo3/cms-core:>= 11.0.0, <= 11.5.34
  • composer/typo3/cms-core:>= 12.0.0, <= 12.4.10
  • composer/typo3/cms-core:= 13.0.0

🔗 References (9)