GHSA-5vp3-v4hc-gx76CriticalCVSS 9.8

UUPSUpgradeable vulnerability in @openzeppelin/contracts

Published
September 15, 2021
Last Modified
January 28, 2023

🔗 CVE IDs covered (1)

📋 Description

Impact

Upgradeable contracts using UUPSUpgradeable may be vulnerable to an attack affecting uninitialized implementation contracts. We will update this advisory with more information soon.

Patches

A fix is included in version 4.3.2 of @openzeppelin/contracts and @openzeppelin/contracts-upgradeable.

Workarounds

Initialize implementation contracts using UUPSUpgradeable by invoking the initializer function (usually called initialize). An example is provided in the forum.

References

Post-mortem.

For more information

If you have any questions or comments about this advisory, or need assistance executing the mitigation, email us at [email protected].

🎯 Affected products2

  • npm/@openzeppelin/contracts:>= 4.1.0, < 4.3.2
  • npm/@openzeppelin/contracts-upgradeable:>= 4.1.0, < 4.3.2

🔗 References (5)