GHSA-5r2g-59px-3q9wMediumCVSS 5.4

Stored XSS using two files in usememos/memos

Published
November 15, 2024
Last Modified
November 19, 2024

🔗 CVE IDs covered (1)

📋 Description

A stored cross-site scripting (XSS) vulnerability was discovered in usememos/memos version 0.9.1. This vulnerability allows an attacker to upload a JavaScript file containing a malicious script and reference it in an HTML file. When the HTML file is accessed, the malicious script is executed. This can lead to the theft of sensitive information, such as login credentials, from users visiting the affected website. The issue has been fixed in version 0.10.0.

🎯 Affected products1

  • go/github.com/usememos/memos:< 0.10.0

🔗 References (5)