GHSA-5mc5-5j6c-qmf9HighCVSS 8.8
cfscrape Improper Input Validation vulnerability
🔗 CVE IDs covered (1)
📋 Description
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
🎯 Affected products1
- pip/cfscrape:>= 1.6.6, <= 1.7.1
🔗 References (6)
- https://nvd.nist.gov/vuln/detail/CVE-2017-7235
- https://github.com/Anorov/cloudflare-scrape/issues/97
- https://github.com/Anorov/cloudflare-scrape/releases/tag/1.8.0
- https://github.com/advisories/GHSA-5mc5-5j6c-qmf9
- https://github.com/pypa/advisory-database/tree/main/vulns/cfscrape/PYSEC-2017-7.yaml
- https://web.archive.org/web/20170701161512/http://www.securityfocus.com/bid/97191