GHSA-5jrv-f37p-8c36unknown

Improper invalidation of cached authorizations vulnerability in Apache ActiveMQ, Apache ActiveMQ...

Published
November 4, 2026
Last Modified
November 4, 2026

🔗 CVE IDs covered (1)

📋 Description

Improper invalidation of cached authorizations vulnerability in Apache ActiveMQ, Apache ActiveMQ Runtime Config.

After the runtime configuration plugin removes a principal's write grant on a destination, an authenticated connection opened before the change can keep sending to that destination, including through a new anonymous producer, while fresh connections and new explicit producers are denied.

This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ Runtime Config: from 6.0.0 before 6.3.3, before 5.19.12.

Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.

🔗 References (4)