GHSA-5gwq-4275-q4qcHighCVSS 7.8

Jenkins AWS CodePipeline Plugin has Insufficiently Protected Credentials

Published
May 13, 2022
Last Modified
January 29, 2023

🔗 CVE IDs covered (1)

📋 Description

Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.

🎯 Affected products1

  • maven/com.amazonaws:aws-codepipeline:< 0.37

🔗 References (4)