GHSA-5frh-wx6v-8m2rMediumCVSS 6.5
CSRF vulnerabilities in Jenkins requests-plugin Plugin
🔗 CVE IDs covered (1)
📋 Description
Jenkins requests-plugin Plugin 2.2.12 and earlier does not require POST requests to request and apply changes, resulting in cross-site request forgery (CSRF) vulnerabilities.
These vulnerabilities allow attackers to create requests and/or have administrators apply pending requests, like renaming or deleting jobs, deleting builds, etc.
Jenkins requests-plugin Plugin 2.2.13 requires POST requests for the affected HTTP endpoints. This was partially fixed in requests-plugin Plugin 2.2.8 to require POST requests for some of the affected HTTP endpoints, but the endpoint allowing administrators to apply pending requests remained unprotected until 2.2.13.
🎯 Affected products1
- maven/org.jenkins-ci.plugins:requests:<= 2.2.12