GHSA-5c8j-xr24-2665CriticalCVSS 9.8
Potential Command Injection in printer
🔗 CVE IDs covered (1)
📋 Description
Versions 0.0.1 and earlier of printer are affected by a command injection vulnerability resulting from a failure to sanitize command arguments properly in the printDirect() function.
Recommendation
Update to version 0.0.2 or later.
🎯 Affected products1
- npm/printer:<= 0.0.1
🔗 References (6)
- https://nvd.nist.gov/vuln/detail/CVE-2014-3741
- https://github.com/tojocky/node-printer/commit/e001e38738c17219a1d9dd8c31f7d82b9c0013c7
- https://github.com/advisories/GHSA-5c8j-xr24-2665
- https://www.npmjs.com/advisories/27
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- http://www.openwall.com/lists/oss-security/2014/05/15/2