GHSA-57rw-qx68-p67cHighCVSS 7.5

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when...

Published
October 30, 2026
Last Modified
October 30, 2026

🔗 CVE IDs covered (1)

📋 Description

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4.

🔗 References (3)