GHSA-56jv-4ww3-65mwMedium

Liferay Portal is vulnerable to XSS in the Blogs widget

Published
October 30, 2025
Last Modified
October 31, 2025

🔗 CVE IDs covered (1)

📋 Description

Cross-site scripting (XSS) vulnerability in the Blogs widget in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.8, 7.4 GA through update 92, 7.3 GA through update 36, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via a crafted injected into a blog entry's “Content” text field.

The Blogs widget in Liferay DXP does not add the sandbox attribute to elements, which allows remote attackers to access the parent page via scripts and links in the frame page.

🎯 Affected products1

  • maven/com.liferay.portal:release.portal.bom:>= 7.4.0-ga1, < 7.4.3.112-ga112

🔗 References (3)