GHSA-5474-f7g5-273qMediumCVSS 4.9

Apache Superset: Improper validation of SQL statements allows for unauthorized access to data

Published
February 28, 2024
Last Modified
March 14, 2026

🔗 CVE IDs covered (1)

📋 Description

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.

Users are recommended to upgrade to version 3.1.1, which fixes the issue.

🎯 Affected products2

  • pip/apache-superset:<= 3.0.3
  • pip/apache-superset:>= 3.1.0, < 3.1.1

🔗 References (4)