GHSA-536q-8gxx-m782Medium

Cross-Site Scripting in dojo

Published
September 11, 2019
Last Modified
January 9, 2023

🔗 CVE IDs covered (1)

📋 Description

Versions of dojo prior to 1.4.2 are vulnerable to DOM-based Cross-Site Scripting (XSS). The package does not sanitize URL parameters in the _testCommon.js and runner.html test files, allowing attackers to execute arbitrary JavaScript in the victim's browser.

Recommendation

Upgrade to version 1.4.2 or later.

🎯 Affected products4

  • npm/dojo:= 1.13.0
  • npm/dojo:>= 1.12.0, < 1.12.4
  • npm/dojo:>= 1.11.0, < 1.11.6
  • npm/dojo:>= 1.10.0, < 1.10.10

🔗 References (20)