GHSA-4w6c-3hcx-rfj5MediumCVSS 4.8

MantisBT vulnerable to XSS through config_option parameter in adm_config_report.php

Published
May 17, 2022
Last Modified
June 9, 2025

🔗 CVE IDs covered (1)

📋 Description

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

🎯 Affected products3

  • composer/mantisbt/mantisbt:< 1.3.9
  • composer/mantisbt/mantisbt:>= 2.1.0, < 2.1.3
  • composer/mantisbt/mantisbt:>= 2.2.0, < 2.2.3

🔗 References (7)