GHSA-4jrw-64vr-7g8mMedium

Apache Camel camel-neo4j component is vulnerable to cypher injection

Published
January 14, 2026
Last Modified
January 15, 2026

🔗 CVE IDs covered (1)

📋 Description

Cypher Injection vulnerability in Apache Camel camel-neo4j component.

This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0

Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.

🎯 Affected products3

  • maven/org.apache.camel:camel-neo4j:>= 4.10.0, < 4.10.8
  • maven/org.apache.camel:camel-neo4j:>= 4.14.0, < 4.14.3
  • maven/org.apache.camel:camel-neo4j:>= 4.15.0, < 4.17.0

🔗 References (11)