GHSA-4c37-7m5h-c8m9MediumCVSS 6.1

Apache Felix Webconsole: XSS in services console

Published
February 10, 2025
Last Modified
February 10, 2025

🔗 CVE IDs covered (1)

📋 Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole.

This issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8.

Users are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.

🎯 Affected products2

  • maven/org.apache.felix:org.apache.felix.webconsole:>= 4.0.0, < 4.9.10
  • maven/org.apache.felix:org.apache.felix.webconsole:>= 5.0.0, < 5.0.10

🔗 References (5)