GHSA-47h6-hfpv-7phjHighCVSS 8.8

Magento 2 Community Edition RCE Vulnerability

Published
May 24, 2022
Last Modified
February 12, 2024

🔗 CVE IDs covered (1)

📋 Description

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with system data manipulation privileges can execute aribitrary code through arbitrary file deletion and OS command injection.

As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

🎯 Affected products2

  • composer/magento/community-edition:>= 2.2, < 2.2.10
  • composer/magento/community-edition:>= 2.3, < 2.3.2-p2

🔗 References (5)