GHSA-44cc-43rp-5947HighCVSS 7.6
JupyterLab vulnerable to potential authentication and CSRF tokens leak
🔗 CVE IDs covered (1)
📋 Description
Impact
Users of JupyterLab who click on a malicious link may get their Authorization and XSRFToken tokens exposed to a third party when running an older jupyter-server version.
Patches
JupyterLab 4.1.0b2, 4.0.11, and 3.6.7 were patched.
Workarounds
No workaround has been identified, however users should ensure to upgrade jupyter-server to version 2.7.2 or newer which includes a redirect vulnerability fix.
References
Vulnerability reported by user @davwwwx via the bug bounty program sponsored by the European Commission and hosted on the Intigriti platform.
🎯 Affected products3
- pip/jupyterlab:>= 4.0.0, <= 4.0.10
- pip/jupyterlab:<= 3.6.6
- pip/notebook:>= 7.0.0, <= 7.0.6
🔗 References (7)
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-44cc-43rp-5947
- https://github.com/jupyterlab/jupyterlab/commit/1ef7a4fa0202ebdf663e1cc0b45c8813a34a0b96
- https://github.com/jupyterlab/jupyterlab/commit/fccd83dc4441da0384ee3fd1322c3b2d9ad4caaa
- https://nvd.nist.gov/vuln/detail/CVE-2024-22421
- https://github.com/jupyterlab/jupyterlab/commit/19bd9b96cb2e77170a67e43121637d0b5619e8c6
- https://lists.fedoraproject.org/archives/list/[email protected]/message/UQJKNRDRFMKGVRIYNNN6CKMNJDNYWO2H/
- https://github.com/advisories/GHSA-44cc-43rp-5947